What’s Vulnerable › Vulnerabilities
CVE-2026-17017: CubeWP Framework < 1.1.31 - Subscriber+ SQL Injection via cubewp_remove_relation
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-09 · updated 2026-08-26
- Weakness: CWE-89
Description
The CubeWP Framework WordPress plugin before 1.1.31 does not properly sanitize and escape a parameter before using it in a SQL statement through an AJAX action, and does not include a capability check on that action, allowing users with Subscriber-level access and above to perform SQL injection attacks.
Affected products
- CubeWP Framework: before 1.1.31 — fixed in 1.1.31
How to fix
Upgrade to a fixed version: CubeWP Framework 1.1.31. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-17017 or the next vulnerability affects your stack