What’s Vulnerable › Vulnerabilities
CVE-2026-17520: Newsletters < 4.17 - Unauthenticated API Access via Predictable API Key
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-29 · updated 2026-08-31
- Weakness: CWE-326
Description
The Newsletters WordPress plugin before 4.17 does not generate its API key using a sufficiently random source, deriving it from a publicly known value, allowing unauthenticated attackers to compute the key and perform privileged actions such as adding and deleting subscribers and sending emails, when the optional API has been enabled.
Affected products
- contrid Newsletters: before 4.17 — fixed in 4.17
How to fix
Upgrade to a fixed version: contrid Newsletters 4.17. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-17520 or the next vulnerability affects your stack