What’s Vulnerable › Vulnerabilities
CVE-2026-17522: Newsletters < 4.17 - Arbitrary Plugin Option Update via CSRF
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-29 · updated 2026-08-31
- Weakness: CWE-352
Description
The Newsletters WordPress plugin before 4.17 does not perform any nonce or capability check when saving one of its settings screens, and writes every submitted parameter into its own options, allowing attackers to make a logged in administrator overwrite arbitrary Newsletters WordPress plugin before 4.17 settings, including the credential protecting its API, via a Cross-Site Request Forgery attack.
Affected products
- contrid Newsletters: before 4.17 — fixed in 4.17
How to fix
Upgrade to a fixed version: contrid Newsletters 4.17. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-17522 or the next vulnerability affects your stack