What’s Vulnerable › Vulnerabilities
CVE-2026-17528
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-28 · updated 2026-07-30
- Weakness: CWE-79
Description
Versions of the package nice-select2 before 2.4.1 are vulnerable to Cross-site Scripting (XSS) via the <select> element. An attacker can supply a malicious payload that is rendered directly into the DOM without proper sanitization, causing arbitrary script execution in a victim’s browser when they view or interact with the affected page.
Affected products
- nice-select2: before 2.4.1 — fixed in 2.4.1
How to fix
Upgrade to a fixed version: nice-select2 2.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/bluzky/nice-select2/commit/ea23ff404e186f6e2a64a25c530f93165fd2ad26
- https://github.com/bluzky/nice-select2/issues/97
- https://security.snyk.io/vuln/SNYK-JS-NICESELECT2-13638683
Get alerted when CVE-2026-17528 or the next vulnerability affects your stack