What’s Vulnerable › Vulnerabilities

CVE-2026-17543: SQL injection in ext-pgsql via E'...' backslash breakout

Description

Improper escaping of backslashes in attacker-provided parameters would allow for trivial SQL injection in PHP versions from 8.2.* before 8.2.33, from 8.3.* before 8.3.33, from 8.4.* before 8.4.24, and from 8.5.* before 8.5.9.

Affected products

How to fix

Upgrade to a fixed version: PHP 8.2.33, 8.3.33, 8.4.24, 8.5.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-17543 or the next vulnerability affects your stack