What’s Vulnerable › Vulnerabilities
CVE-2026-17559: Content Protector (Passster) < 4.3.9 - Unauthenticated Protected Content Disclosure via REST Path Allowlist Bypass
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-21 · updated 2026-10-16
- Weakness: CWE-863
Description
The Passster WordPress plugin before 4.3.9 does not correctly match its own public endpoint paths when deciding which REST API requests may bypass global password protection, comparing them as an unanchored substring of the request URI rather than against the resolved route, allowing an unauthenticated attacker to read the content of globally password-protected posts and pages.
Affected products
- Passster: from 4.3.3 before 4.3.9 — fixed in 4.3.9
How to fix
Upgrade to a fixed version: Passster 4.3.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-17559 or the next vulnerability affects your stack