What’s Vulnerable › Vulnerabilities

CVE-2026-17570

Description

Improper access control in the PAM password history endpoints in Devolutions Server allows an authenticated low-privileged user to disclose plaintext credential secrets via crafted API requests. This issue affects : * Devolutions Server 2026.2.4.0 through 2026.2.12.0 * Devolutions Server 2026.1.23.0 and earlier

Affected products

How to fix

Upgrade to a fixed version: Devolutions Server 2026.1.24.0, 2026.2.14.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-17570 or the next vulnerability affects your stack