What’s Vulnerable › Vulnerabilities
CVE-2026-17596: Nexus Repository 3 - Stored Cross-Site Scripting (XSS) via Blob Store Name
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-07 · updated 2026-09-22
- Weakness: CWE-79
Description
Nexus Repository 3 was found to be vulnerable to stored cross-site scripting (XSS). A user with the nexus:blobstores:create or nexus:blobstores:update permission could set a blob store name containing malicious script content, which would later execute in the browser of another user viewing system health-check status. This issue has been fixed in version 3.95.0.
Affected products
- Sonatype Nexus Repository 3: from 3.16.0 before 3.95.0 — fixed in 3.95.0
How to fix
Upgrade to a fixed version: Sonatype Nexus Repository 3 3.95.0. Check the vendor advisory for mitigations.
References
- https://help.sonatype.com/en/sonatype-nexus-repository-3-95-0-release-notes.html
- https://support.sonatype.com/hc/en-us/articles/53871280401555/
Get alerted when CVE-2026-17596 or the next vulnerability affects your stack