What’s Vulnerable › Vulnerabilities

CVE-2026-17624: Langflow OSS is affected by arbitrary code execution in component generation, validation, and custom component handling

Description

IBM Langflow OSS 1.0.0 through 1.10.3, 1.0.0 through 1.10.3, 1.0.0 through 1.10.3, 1.0.0 through 1.10.3, 1.0.0 through 1.10.3, 1.0.0 through 1.10.3, and 1.0.0 through 1.10.3 could allow a remote authenticated attacker to execute arbitrary code due to improper validation of module imports.

Affected products

How to fix

Upgrade to a fixed version: IBM Langflow OSS 1.11.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-17624 or the next vulnerability affects your stack