What’s Vulnerable › Vulnerabilities
CVE-2026-17625: Langflow is affected by OS Command Injection in Model Context Protocol features
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-05 · updated 2026-08-06
- Weakness: CWE-78
Description
IBM Langflow OSS 1.0.0 through 1.10.3, 1.0.0 through 1.10.3, 1.0.0 through 1.10.3, 1.0.0 through 1.10.3, 1.0.0 through 1.10.3, 1.0.0 through 1.10.3, and 1.0.0 through 1.10.3 could allow a remote authenticated attacker to execute arbitrary commands due to improper neutralization of special elements used in an OS command.
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.11.0 — fixed in 1.11.0
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.11.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-17625 or the next vulnerability affects your stack