What’s Vulnerable › Vulnerabilities
CVE-2026-17627: Langflow is affected by improper authorization due to missing access control on the voice-mode WebSocket endpoint
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-09
- Weakness: CWE-639
Description
IBM Langflow OSS 1.0.0 through 1.10.2 could allow a remote authenticated attacker to obtain sensitive information and inject messages into workflow history due to improper authorization.
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.10.3 — fixed in 1.10.3
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.10.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-17627 or the next vulnerability affects your stack