What’s Vulnerable › Vulnerabilities
CVE-2026-17631: Langflow OSS is affected by server-side request forgery due to missing URL validation in flow components
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-09
- Weakness: CWE-918
Description
IBM Langflow OSS 1.0.0 through 1.10.2 could allow a remote authenticated attacker to obtain sensitive information due to a server-side request forgery (SSRF) vulnerability.
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.10.3 — fixed in 1.10.3
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.10.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-17631 or the next vulnerability affects your stack