What’s Vulnerable › Vulnerabilities
CVE-2026-18030: Bricksforge < 3.1.8.8 - Unauthenticated Arbitrary Password Reset via Pro Forms
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-08-26
- Weakness: CWE-862
Description
The BricksForge WordPress plugin before 3.1.8.8 does not verify the identity of the requester when processing a password change submitted through one of its form actions, allowing unauthenticated attackers to set an arbitrary password for any user, including administrators, and take over their account. Exploitation requires the site to have a form using the BricksForge WordPress plugin before 3.1.8.8's password reset action in its update mode. The server-side current-password verification option for that action is disabled by default, so the vulnerable state is the default one once the action is used.
Affected products
- BricksForge: before 3.1.8.8 — fixed in 3.1.8.8
How to fix
Upgrade to a fixed version: BricksForge 3.1.8.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-18030 or the next vulnerability affects your stack