What’s Vulnerable › Vulnerabilities
CVE-2026-18032: WP Data Access < 5.5.79 - Unauthenticated Sensitive Data Disclosure via Autocomplete Column Authorization Bypass
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-09 · updated 2026-08-26
- Weakness: CWE-200
Description
The WP Data Access WordPress plugin before 5.5.79 does not validate the column names it accepts on one of its unauthenticated AJAX actions, and the nonce guarding that action does not cover them, allowing unauthenticated attackers to read arbitrary columns of the database table the affected front-end form is bound to, including user password hashes where that table is the users table.
Affected products
- peterschulznl WP Data Access – App Builder for Tables, Forms, Charts, Maps & Dashboards: before 5.5.79 — fixed in 5.5.79
How to fix
Upgrade to a fixed version: peterschulznl WP Data Access – App Builder for Tables, Forms, Charts, Maps & Dashboards 5.5.79. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-18032 or the next vulnerability affects your stack