What’s Vulnerable › Vulnerabilities
CVE-2026-18061: Improper Restriction of XML External Entity References in AWS Advanced JDBC Wrapper RemoteQueryCachePlugin
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-11 · updated 2026-09-16
- Weakness: CWE-611
Description
Improper restriction of XML external entity references in the RemoteQueryCachePlugin in AWS Advanced JDBC Wrapper 3.3.0 through 4.2.0 might allow an actor with write access to the shared cache infrastructure to disclose sensitive files from application hosts that read cached query results, including stored database and IAM role credentials, via crafted XML data in a cached column value. To remediate this issue, users should upgrade to version 4.3.0 or later.
Affected products
- AWS Advanced JDBC Wrapper: from 3.3.0 before 4.3.0 — fixed in 4.3.0
How to fix
Upgrade to a fixed version: AWS Advanced JDBC Wrapper 4.3.0. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-109-aws/
- https://github.com/aws/aws-advanced-jdbc-wrapper/releases/tag/4.3.0
- https://github.com/aws/aws-advanced-jdbc-wrapper/security/advisories/GHSA-fpvp-qwgm-v6h9
Get alerted when CVE-2026-18061 or the next vulnerability affects your stack