What’s Vulnerable › Vulnerabilities
CVE-2026-18119: Concrete CMS below 9.5.3 is vulnerable to Stored XSS via unsanitized inline block custom style values
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-14 · updated 2026-09-18
- Weakness: CWE-79
Description
Concrete CMS below 9.5.3 did not sanitize custom style values in the Block Design dialog before writing them into page CSS via a DOM sink, permitting stored cross-site scripting. An editor-level user could execute script in an administrator's session and escalate privileges. The Concrete CMS security team gave this vulnerability a CVSS v4.0 score of 7.0 with vector CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:H/VA:H/SC:N/SI:N/SA:N. Thanks Nguyen Manh Thuan for reporting.
Affected products
- Concrete CMS: before 9.5.3 — fixed in 9.5.3
How to fix
Upgrade to a fixed version: Concrete CMS 9.5.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-18119 or the next vulnerability affects your stack