What’s Vulnerable › Vulnerabilities
CVE-2026-18157: Yggdrasil-worker-package-manager: yggdrasil-worker-package-manager: remote code execution via apt argument injection
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-31 · updated 2026-10-23
- Weakness: CWE-88
Description
A flaw was found in yggdrasil-worker-package-manager. A local attacker with existing access to the system could exploit an argument injection vulnerability in the APT backend. This allows specially crafted package names, which begin with a hyphen, to be misinterpreted as command options by apt-get. Successful exploitation could lead to remote code execution (RCE) with root privileges, enabling the attacker to fully compromise the system's integrity, confidentiality, and availability.
Affected products
- RedHatInsights yggdrasil-worker-package-manager: before 0.1.4; from 0.2.0 before 0.2.4 — fixed in 0.1.4, 0.2.4
How to fix
Upgrade to a fixed version: RedHatInsights yggdrasil-worker-package-manager 0.1.4, 0.2.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2026-18157
- https://bugzilla.redhat.com/show_bug.cgi?id=2465250
- https://github.com/RedHatInsights/yggdrasil-worker-package-manager/commit/959745bb5917c17f0316af199aace6c71baa5ad7
- https://github.com/RedHatInsights/yggdrasil-worker-package-manager/releases/tag/0.1.4
- https://github.com/RedHatInsights/yggdrasil-worker-package-manager/releases/tag/0.2.4
Get alerted when CVE-2026-18157 or the next vulnerability affects your stack