What’s Vulnerable › Vulnerabilities
CVE-2026-18165: @fastify/oauth2 vulnerable to Login CSRF via plantable OAuth state cookies
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-15 · updated 2026-09-04
- Weakness: CWE-352
Description
@fastify/oauth2 is an OAuth 2.0 plugin for Fastify. In versions from 7.2.0 up to but not including 8.3.0, the plugin validates the OAuth state, and with PKCE the code verifier, by comparing the callback query parameter against an unprefixed, predictable cookie, with no server-side binding to the browser that began the flow. Any party able to write a cookie for the application's host, such as a sibling subdomain under the same registrable domain, can plant matching state and verifier cookies and complete an attacker-owned OAuth flow inside a victim's browser, silently signing the victim in to the attacker's account (login CSRF). It does not expose the victim's own account, credentials, or tokens. The issue is fixed in @fastify/oauth2 8.3.0, which adds an opt-in hostPrefixedCookies option. Users should upgrade to 8.3.0 and enable it, or bind state to a server-side session.
Affected products
- Fastify/Oauth2: from 7.2.0 before 8.3.0 — fixed in 8.3.0
How to fix
Upgrade to a fixed version: Fastify/Oauth2 8.3.0. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/fastify/fastify-oauth2/security/advisories/GHSA-p8h8-rj28-m8q9
Get alerted when CVE-2026-18165 or the next vulnerability affects your stack