What’s Vulnerable › Vulnerabilities
CVE-2026-18167: Stack-based buffer overflow in TP-Link Archer AX55 v4
- Severity: high (CVSS 7.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-03 · updated 2026-09-08
- Weakness: CWE-121
Description
A stack-based buffer overflow vulnerability exists in the EasyMesh module of TP-Link Archer AX55 v4. When Mesh mode is enabled, a LAN attacker may submit crafted input that causes the easymesh daemon to crash and may potentially achieve remote code execution on the device. Successful exploitation may cause the EasyMesh daemon to crash and may potentially allow remote code execution when Mesh mode is enabled. This may result in high impact to the confidentiality, integrity, and availability of the affected device.
Affected products
- TP-Link Systems Inc. Archer AX55 v4: before 1.2.1 Build 20260527 — fixed in 1.2.1 Build 20260527
How to fix
Upgrade to a fixed version: TP-Link Systems Inc. Archer AX55 v4 1.2.1 Build 20260527. Check the vendor advisory for mitigations.
References
- https://www.tp-link.com/us/support/download/archer-ax55/v4/#Firmware
- https://www.tp-link.com/us/support/faq/5279/
Get alerted when CVE-2026-18167 or the next vulnerability affects your stack