What’s Vulnerable › Vulnerabilities

CVE-2026-18244: Missing Authorization in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 17.7 before 19.0.6, 19.1 before 19.1.4, and 19.2 before 19.2.2 that under certain conditions could have allowed an authenticated user to view restricted configuration settings due to improper authorization checks on a group settings page.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.0.6, 19.1.4, 19.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-18244 or the next vulnerability affects your stack