What’s Vulnerable › Vulnerabilities
CVE-2026-18245: Incomplete fix for CVE-2025-4318 code injection in Amazon @aws-amplify/codegen-ui-react
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-30 · updated 2026-10-23
- Weakness: CWE-94
Description
Improper control of code generation in Amazon @aws-amplify/codegen-ui-react before 2.20.6 might allow a remote authenticated user to execute arbitrary code in end-user browsers, developer machines, CI/CD environments, and server-side rendering contexts via crafted Studio component or theme schema values due to insufficient coverage and effectiveness of the input validation introduced for CVE-2025-4318. To remediate this issue, users should upgrade to version 2.20.6
Affected products
- AWS Amplify Codegen UI: before 2.20.6 — fixed in 2.20.6
How to fix
Upgrade to a fixed version: AWS Amplify Codegen UI 2.20.6. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-066-aws/
- https://github.com/aws-amplify/amplify-codegen-ui/releases/tag/v2.20.6
- https://github.com/aws-amplify/amplify-codegen-ui/security/advisories/GHSA-74xx-rjgf-m69j
Get alerted when CVE-2026-18245 or the next vulnerability affects your stack