What’s Vulnerable › Vulnerabilities

CVE-2026-18252: Inclusion of Functionality from Untrusted Control Sphere in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 18.9 before 19.1.7, 19.2 before 19.2.5, and 19.3 before 19.3.1 that, under certain conditions, an authenticated user with developer-role permissions could have executed arbitrary commands in a CI context, due to the Claude agent processing configuration from a user-controlled source.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.1.7, 19.2.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-18252 or the next vulnerability affects your stack