What’s Vulnerable › Vulnerabilities
CVE-2026-18299: GStreamer rtpsbcdepay Use-After-Free Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-20 · updated 2026-10-26
- Weakness: CWE-416
Description
GStreamer rtpsbcdepay Use-After-Free Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the processing of RTP payload elements. The issue results from the lack of validating the existence of an object prior to performing operations on the object. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-29787.
Affected products
- GStreamer: before 1.28.5 — fixed in 1.28.5
How to fix
Upgrade to a fixed version: GStreamer 1.28.5. Check the vendor advisory for mitigations.
References
- https://gstreamer.freedesktop.org/security/sa-2026-0051.html
- https://www.zerodayinitiative.com/advisories/ZDI-26-467/
Get alerted when CVE-2026-18299 or the next vulnerability affects your stack