What’s Vulnerable › Vulnerabilities
CVE-2026-18391: WooCommerce Subscriptions < 9.1.0 - Unauthenticated RCE via PHP Object Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-12 · updated 2026-08-26
- Weakness: CWE-434
Description
The WooCommerce Subscriptions WordPress plugin before 9.1.0 does not validate user input before unserializing it on stores with High-Performance Order Storage enabled, leading to a PHP Object Injection issue which unauthenticated users can escalate to Remote Code Execution via a gadget chain present in the bundled dependencies.
Affected products
- WooCommerce Subscriptions: from 4.7.0 before 9.1.0 — fixed in 9.1.0
How to fix
Upgrade to a fixed version: WooCommerce Subscriptions 9.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-18391 or the next vulnerability affects your stack