What’s Vulnerable › Vulnerabilities

CVE-2026-18433: Incorrect Authorization in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 19.1 before 19.1.4 and 19.2 before 19.2.2 that under certain conditions could have allowed an authenticated user to read policy configuration belonging to a namespace they were not authorized to access, due to incorrect authorization checks in a GraphQL query.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.1.4, 19.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-18433 or the next vulnerability affects your stack