What’s Vulnerable › Vulnerabilities
CVE-2026-18446: fast-uri vulnerable to host confusion via backslash authority introducer
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-31 · updated 2026-09-02
- Weakness: CWE-436
Description
fast-uri before 4.1.2, 3.1.5, and 2.4.4 requires a literal double forward slash to recognize a URI authority, so a reference that uses a backslash based introducer in place of it (backslash backslash, forward slash backslash, or backslash forward slash) is parsed with no authority and folds into the path. Node's native WHATWG URL parser instead treats a backslash as interchangeable with a forward slash for special schemes, so the two parsers extract different hosts from the same input. Applications that use fast-uri to enforce host based policy such as allowlists, SSRF filtering, or redirect validation before passing the same URL into Node's URL or fetch consumers can be steered to an unintended host. Upgrade to fast-uri 4.1.2, 3.1.5, or 2.4.4.
Affected products
- fast-uri: before 2.4.4; from 3.0.0 before 3.1.5; from 4.0.0 before 4.1.2 — fixed in 2.4.4, 3.1.5, 4.1.2
How to fix
Upgrade to a fixed version: fast-uri 2.4.4, 3.1.5, 4.1.2. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/fastify/fast-uri/security/advisories/GHSA-7p8r-x3mc-p8w7
Get alerted when CVE-2026-18446 or the next vulnerability affects your stack