What’s Vulnerable › Vulnerabilities
CVE-2026-18459: Incorrect Calculation vulnerability in RTI Connext Professional (Core Libraries) allows Abuse Existing Functionality.
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-22 · updated 2026-09-22
- Weakness: CWE-682
Description
Incorrect Calculation vulnerability in RTI Connext Professional (Core Libraries) allows Abuse Existing Functionality. This issue affects Connext Professional: from 7.4.0 before 7.7.0.1, from 7.0.0 before 7.3.1.6, from 6.1.0 before 6.1.*, from 6.0.0 before 6.0.*, from 5.3.0 before 5.3.*, from 5.2.0 before 5.2.*, from 4.1x before 5.1.*.
Affected products
- RTI Connext Professional: from 7.4.0 before 7.7.0.1; from 7.0.0 before 7.3.1.6; 6.1.x from 6.1.0; 6.0.x from 6.0.0; 5.3.x from 5.3.0; 5.2.x from 5.2.0 — fixed in 7.3.1.6, 7.7.0.1
How to fix
Upgrade to a fixed version: RTI Connext Professional 7.3.1.6, 7.7.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-18459 or the next vulnerability affects your stack