What’s Vulnerable › Vulnerabilities
CVE-2026-1850: An authorized user may disable the MongoDB server by issuing a certain type of complex query due to boolean expression simplification
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-10 · updated 2026-06-17
- Weakness: CWE-770
Description
Complex queries can cause excessive memory usage in MongoDB Query Planner resulting in an Out-Of-Memory Crash.
Affected products
- MongoDB: from 8.0.0 before 8.0.18; from 8.2.0 before 8.2.4 — fixed in 8.0.18, 8.2.4
How to fix
Upgrade to a fixed version: MongoDB 8.0.18, 8.2.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-1850 or the next vulnerability affects your stack