What’s Vulnerable › Vulnerabilities
CVE-2026-18504: fastify vulnerable to schema validation bypass via root primitive coercion mismatch
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-09-02
- Weakness: CWE-20
Description
fastify is a fast and low overhead web framework for Node.js. Versions of fastify before 5.12.1 are affected by a schema validation bypass when a request body schema targets a root primitive value. When the schema validates a top-level primitive such as an integer, Ajv can coerce a JSON string into the expected type during validation, but Fastify does not replace the root request body with the coerced value, so the route handler receives the original unvalidated string. As a result, a request that should have failed validation can reach application logic with a value that does not satisfy the schema, which can undermine integrity and access-control checks that rely on the validated type. Users should upgrade to fastify 5.12.1, which fixes the mismatch. No known workarounds are available.
Affected products
- fastify: before 5.12.1 — fixed in 5.12.1
How to fix
Upgrade to a fixed version: fastify 5.12.1. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/fastify/fastify/security/advisories/GHSA-w2qp-rph6-63g4
Get alerted when CVE-2026-18504 or the next vulnerability affects your stack