What’s Vulnerable › Vulnerabilities
CVE-2026-18540: undici vulnerable to downstream response splitting via retry interceptor
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-16
- Weakness: CWE-444
Description
undici's retry interceptor can append the body of a ranged retry response to bytes already delivered from an earlier partial response while still presenting the original response's status and headers. This happens when an upstream server delivers part of a body without a trustworthy resume checkpoint, for example a non-success response whose headers were already sent or a partial-content response with an unusable content range, then closes the connection and answers the resumed range request with more bytes. As a result the response body can be longer than the Content-Length that the application observes. An application that relays such a response to a downstream HTTP/1.1 peer without normalizing the framing can emit a body that exceeds the forwarded Content-Length, and the excess bytes can be interpreted as the start of a following response, which enables downstream response splitting or desynchronization. Exploitation requires an attacker-controlled upstream server and an application that forwards the response through a framing-sensitive path. This affects undici versions before 6.28.1, from 7.0.0 up to 7.29.1, and from 8.0.0 up to 8.10.2. Users should upgrade to undici 6.28.1, 7.29.1, or 8.10.2.
Affected products
- undici: before 6.28.1; from 7.0.0 before 7.29.1; from 8.0.0 before 8.10.2 — fixed in 6.28.1, 7.29.1, 8.10.2
- Npm Undici: before 6.28.1; from 7.0.0 before 7.29.1; from 8.0.0 before 8.10.2 — fixed in 6.28.1, 7.29.1, 8.10.2
How to fix
Upgrade to a fixed version: undici 6.28.1, 7.29.1, 8.10.2; Npm Undici 6.28.1, 7.29.1, 8.10.2. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/nodejs/undici/security/advisories/GHSA-r53p-7pc4-xj5r
Get alerted when CVE-2026-18540 or the next vulnerability affects your stack