What’s Vulnerable › Vulnerabilities

CVE-2026-18560: Improper order of authorisations in Mattermost GetFile API leads to an authenticated user to determine a post’s quarantined status

Description

Mattermost versions 11.10.x <= 11.10.0, 11.7.x <= 11.7.9, 11.9.x <= 11.9.1, 11.8.x <= 11.8.5 fail to validate user’s permissions before other validations which allows non-content reviewers to infer a post’s flagged status via direct API call.. Mattermost Advisory ID: MMSA-2026-00754

Affected products

How to fix

Upgrade to a fixed version: Mattermost 11.7.10, 11.8.6, 11.9.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-18560 or the next vulnerability affects your stack