What’s Vulnerable › Vulnerabilities
CVE-2026-18687: Improper Validation in MongoDB Queryable Encryption Maintenance Operation Leads to Denial of Service and Index Corruption
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-11 · updated 2026-10-23
- Weakness: CWE-191
Description
MongoDB Server's handling of a Queryable Encryption maintenance operation did not properly validate certain request parameters against the collection's encrypted field configuration before use. An authenticated user with readWrite privileges could submit a specially formed request that leads to a server crash or excessive internal writes, resulting in resource exhaustion and corruption of encrypted index data.
Affected products
- MongoDB: from 8.0.0 before 8.0.29; from 8.2.0 through 8.2.12; from 8.3.0 before 8.3.8; 9.0.0-alpha0, 9.0.0-alpha1, 9.1.0-alpha0 — fixed in 8.0.29, 8.3.8
How to fix
Upgrade to a fixed version: MongoDB 8.0.29, 8.3.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-18687 or the next vulnerability affects your stack