What’s Vulnerable › Vulnerabilities
CVE-2026-18697: Improper Input Validation in MongoDB Aggregation Framework Allows Unauthenticated Denial of Service on mongos
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-11 · updated 2026-10-23
- Weakness: CWE-617
Description
An issue in MongoDB Server's aggregation framework could allow an unauthenticated party to cause a mongos (router) process to terminate unexpectedly by submitting a specially formed aggregation command. This could result in a denial of service, disrupting client connections routed through the affected mongos instance.
Affected products
- MongoDB: from 7.0.0 before 7.0.40; from 8.0.0 before 8.0.29; from 8.2.0 through 8.2.12; from 8.3.0 before 8.3.8; 9.0.0-alpha0, 9.0.0-alpha1, 9.1.0-alpha0 — fixed in 7.0.40, 8.0.29, 8.3.8
How to fix
Upgrade to a fixed version: MongoDB 7.0.40, 8.0.29, 8.3.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-18697 or the next vulnerability affects your stack