What’s Vulnerable › Vulnerabilities
CVE-2026-18704: Improper Authorization in MongoDB Aggregation Framework Allows Read-Only User to Perform Unauthorized Write Operations
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-11 · updated 2026-10-23
- Weakness: CWE-862
Description
An issue in MongoDB Server's aggregation framework could allow an authenticated user with only read privileges to perform write operations against collections they should not be able to modify. This is due to an internal-use aggregation stage being reachable by external clients without an appropriate authorization check on its embedded operations.
Affected products
- MongoDB: from 8.3.0 before 8.3.8 — fixed in 8.3.8
How to fix
Upgrade to a fixed version: MongoDB 8.3.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-18704 or the next vulnerability affects your stack