What’s Vulnerable › Vulnerabilities
CVE-2026-18707: Improper Input Validation in MongoDB Aggregation Command Handling Leads to Denial of Service
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-11 · updated 2026-09-16
- Weakness: CWE-617
Description
An issue in MongoDB Server could allow an authenticated user, including one with no assigned privileges, to cause the server process to terminate unexpectedly by submitting a specially formed aggregation command. This could result in a denial of service.
Affected products
- MongoDB: from 7.0.0 before 7.0.40; from 8.0.0 before 8.0.29; from 8.2.0 through 8.2.12; from 8.3.0 before 8.3.8; 9.0.0-alpha0, 9.0.0-alpha1, 9.1.0-alpha0 — fixed in 7.0.40, 8.0.29, 8.3.8
How to fix
Upgrade to a fixed version: MongoDB 7.0.40, 8.0.29, 8.3.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-18707 or the next vulnerability affects your stack