What’s Vulnerable › Vulnerabilities
CVE-2026-18729: Langflow is affected by multiple remote code execution vulnerabilities due to insufficient code-execution policy enforcement
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-09-01
- Weakness: CWE-94
Description
IBM Langflow OSS 1.0.0 through 1.11.1 could allow a remote authenticated attacker to execute arbitrary code due to improper control of generation of code.
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.11.2 — fixed in 1.11.2
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.11.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-18729 or the next vulnerability affects your stack