What’s Vulnerable › Vulnerabilities
CVE-2026-18733: Prompt injection bypasses shell tool consent gate in Strands Agents Tools
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-03 · updated 2026-10-23
- Weakness: CWE-1427
Description
A prompt injection vulnerability in the shell tool in Amazon Strands Agents Tools before 0.8.0 might allow remote actors to execute arbitrary operating system commands on the agent's host via a crafted prompt that sets the non_interactive parameter to true, bypassing the human consent gate. To remediate this issue, users should upgrade to version 0.8.0.
Affected products
- AWS strands-agents-tools: before 0.8.0 — fixed in 0.8.0
How to fix
Upgrade to a fixed version: AWS strands-agents-tools 0.8.0. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-072-aws/
- https://github.com/strands-agents/tools/security/advisories/GHSA-mqvc-p852-wf8x
- https://pypi.org/project/strands-agents-tools/0.8.0/
Get alerted when CVE-2026-18733 or the next vulnerability affects your stack