What’s Vulnerable › Vulnerabilities
CVE-2026-18779: TrueBooker Appointment Booking < 1.2.7 - Unauthenticated Appointment and Payment Record Deletion via update_appointment_booked
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-08-26
- Weakness: CWE-862
Description
The TrueBooker WordPress plugin before 1.2.7 does not have proper authorisation checks in one of its AJAX actions, allowing unauthenticated users to delete arbitrary appointment records along with their associated booking items and payment records.
Affected products
- TrueBooker: before 1.2.7 — fixed in 1.2.7
How to fix
Upgrade to a fixed version: TrueBooker 1.2.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-18779 or the next vulnerability affects your stack