What’s Vulnerable › Vulnerabilities
CVE-2026-18786: CheckView < 2.3.2 - Administrator Account Creation via REST API Authentication Bypass
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-08-26
- Weakness: CWE-287
Description
The CheckView WordPress plugin before 2.3.2 does not restrict its REST API authentication filter to its own routes and unconditionally discards the authentication error raised for any request whose URI merely contains a CheckView WordPress plugin before 2.3.2-specific string, making it possible for unauthenticated attackers to bypass the REST nonce check and perform any REST action available to a logged-in administrator, such as creating a new administrator account, via a crafted link an administrator is tricked into opening.
Affected products
- CheckView: from 2.0.29 before 2.3.2 — fixed in 2.3.2
How to fix
Upgrade to a fixed version: CheckView 2.3.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-18786 or the next vulnerability affects your stack