What’s Vulnerable › Vulnerabilities
CVE-2026-18807: ECS < 4.3.13 - Contributor+ Arbitrary Post Binding and Global Preset Modification via Dynamic Repeater Handlers
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-15 · updated 2026-10-16
- Weakness: CWE-862
Description
The ECS WordPress plugin before 4.3.13 does not have capability or ownership checks on its dynamic repeater actions, relying only on a nonce available to any user who can open the page builder, allowing users with a contributor-level account or above to read, alter and delete the binding configuration of posts they do not own and to change the ECS WordPress plugin before 4.3.13's site-wide presets.
Affected products
- ECS: before 4.3.13 — fixed in 4.3.13
How to fix
Upgrade to a fixed version: ECS 4.3.13. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-18807 or the next vulnerability affects your stack