What’s Vulnerable › Vulnerabilities
CVE-2026-18816: Baserow 2FA Verify Endpoint views.py verify improper authentication
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-04 · updated 2026-08-12
- Weakness: CWE-287
Description
A vulnerability was identified in Baserow up to 2.3.2. Affected by this vulnerability is the function verify of the file backend/src/baserow/api/two_factor_auth/views.py of the component 2FA Verify Endpoint. Such manipulation leads to improper authentication. The attack may be launched remotely. This attack is characterized by high complexity. The exploitation appears to be difficult. Upgrading to version 2.3.3 addresses this issue. You should upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
Affected products
- Baserow: 2.3.0, 2.3.1, 2.3.2
References
- https://github.com/baserow/baserow/
- https://github.com/baserow/baserow/issues/5743
- https://github.com/baserow/baserow/releases/tag/2.3.3
- https://vuldb.com/cve/CVE-2026-18816
- https://vuldb.com/submit/857941
- https://vuldb.com/vuln/385815
- https://vuldb.com/vuln/385815/cti
Get alerted when CVE-2026-18816 or the next vulnerability affects your stack