What’s Vulnerable › Vulnerabilities
CVE-2026-18918: OAuth 1.0 session-fixation chain via unauthenticated provisional-consumer registration and insecure v1_0Allowed default
- Severity: critical (CVSS 9.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-09-01
- Weakness: CWE-863
Description
In Eclipse Lyo versions 2.0.0 to 7.0.0, OAuth server authorization checks can be bypassed when the 2-legged auth is supported by the server. In those cases, application that based their authz filters upon Lyo-provided `AbstractAdapterCredentialsFilter`, are vulnerable. An attacked can create a provisional trusted client (valid use-case) but then it can be used as a trusted client immediately without requiring the administrator approval to clear the provisional status. The 3-legged path requiring user interaction is not vulnerable and rejects provisional clients.
Affected products
- Eclipse Foundation Eclipse Lyo: from 2.0.0 before 7.0.0 — fixed in 7.0.0
How to fix
Upgrade to a fixed version: Eclipse Foundation Eclipse Lyo 7.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/eclipse-lyo/lyo/releases/tag/v6.0.1.Final
- https://github.com/eclipse-lyo/lyo/releases/tag/v7.0.0.Beta3
- https://gitlab.eclipse.org/security/cve-assignment/-/work_items/221
Get alerted when CVE-2026-18918 or the next vulnerability affects your stack