What’s Vulnerable › Vulnerabilities
CVE-2026-1892: WeKan REST API boards.js setBoardOrgs improper authorization
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-04 · updated 2026-06-17
- Weakness: CWE-266
Description
A security vulnerability has been detected in WeKan up to 8.20. This affects the function setBoardOrgs of the file models/boards.js of the component REST API. Such manipulation of the argument item.cardId/item.checklistId/card.boardId leads to improper authorization. The attack may be launched remotely. A high complexity level is associated with this attack. The exploitability is reported as difficult. Upgrading to version 8.21 mitigates this issue. The name of the patch is cabfeed9a68e21c469bf206d8655941444b9912c. It is suggested to upgrade the affected component.
Affected products
- WeKan: before 8.21 — fixed in 8.21
How to fix
Upgrade to a fixed version: WeKan 8.21. Check the vendor advisory for mitigations.
References
- https://github.com/wekan/wekan/
- https://github.com/wekan/wekan/commit/cabfeed9a68e21c469bf206d8655941444b9912c
- https://github.com/wekan/wekan/releases/tag/v8.21
- https://vuldb.com/?ctiid.344265
- https://vuldb.com/?id.344265
- https://vuldb.com/?submit.742662
Get alerted when CVE-2026-1892 or the next vulnerability affects your stack