What’s Vulnerable › Vulnerabilities
CVE-2026-18937: Broken Link Checker < 2.4.12 - Unauthenticated RCE via Query Variable Injection
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-19 · updated 2026-08-26
- Weakness: CWE-94
Description
The Broken Link Checker WordPress plugin before 2.4.12 does not limit which query variables it accepts from user input on sites using plain permalinks, allowing unauthenticated users to overwrite arbitrary PHP global variables, and to execute arbitrary code on the server when a classic (non-block) is active.
Affected products
- wpmudev Broken Link Checker: before 2.4.12 — fixed in 2.4.12
How to fix
Upgrade to a fixed version: wpmudev Broken Link Checker 2.4.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-18937 or the next vulnerability affects your stack