What’s Vulnerable › Vulnerabilities
CVE-2026-18945: WP Helper Premium < 4.7.6 - Unauthenticated Order Data Disclosure and Order Manipulation via Missing Order Key Validation
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-08-26
- Weakness: CWE-639
Description
The WP Helper Premium WordPress plugin before 4.7.6 does not verify the order key when rendering its custom order confirmation page or when handling the related AJAX actions, allowing unauthenticated users to view other customers' order details, including personal information, as well as change the state of arbitrary orders. Exploitation requires WooCommerce to be active and the WP Helper Premium WordPress plugin before 4.7.6's optional order confirmation page module to be enabled.
Affected products
- WP Helper Premium: before 4.7.6 — fixed in 4.7.6
How to fix
Upgrade to a fixed version: WP Helper Premium 4.7.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-18945 or the next vulnerability affects your stack