What’s Vulnerable › Vulnerabilities
CVE-2026-18952: Missing Input Validation in Threat Intel Feed Parser in OpenSearch Security Analytics Plugin
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-12 · updated 2026-08-21
- Weakness: CWE-918
Description
Missing input validation in the threat intelligence feed parser in the OpenSearch Security Analytics plugin might allow an authenticated remote user to perform server-side request forgery and read local files via a crafted URL parameter to the threat intel source configuration endpoint.
Affected products
- AWS Opensearch: from 2.15.0 before 3.5.0 — fixed in 3.5.0
- Github Opensearch: from 2.15.0 before 3.7.0 — fixed in 3.7.0
How to fix
Upgrade to a fixed version: AWS Opensearch 3.5.0; Github Opensearch 3.7.0. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-079-aws/
- https://docs.aws.amazon.com/opensearch-service/latest/developerguide/service-software.html
- https://github.com/opensearch-project/security-analytics/security/advisories/GHSA-w946-8jxc-6v3m
Get alerted when CVE-2026-18952 or the next vulnerability affects your stack