What’s Vulnerable › Vulnerabilities
CVE-2026-18954: Incorrect authorization in the aggregation pipeline tool in Amazon AWS Labs DocumentDB MCP Server
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-05 · updated 2026-10-23
- Weakness: CWE-863
Description
Incorrect authorization in the aggregation pipeline tool in Amazon AWS Labs DocumentDB MCP Server before 1.0.12 might allow an authenticated MCP client to perform inappropriate write operations on the connected database via write-capable aggregation pipeline stages that bypass the read-only mode enforcement logic. To remediate this issue, users should upgrade to version 1.0.12 or later.
Affected products
- AWS documentdb-mcp-server: before 1.0.12 — fixed in 1.0.12
How to fix
Upgrade to a fixed version: AWS documentdb-mcp-server 1.0.12. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-076-aws/
- https://github.com/awslabs/mcp/releases/tag/2026.04.20260408085348
- https://github.com/awslabs/mcp/security/advisories/GHSA-j694-4m5j-w8hc
Get alerted when CVE-2026-18954 or the next vulnerability affects your stack