What’s Vulnerable › Vulnerabilities

CVE-2026-19012: Authenticated denial of service in Consul Enterprise-to-Community Edition downgrade path

Description

Consul Community Edition and Consul Enterprise 1.18.0 through 2.0.2 are vulnerable to an authenticated denial of service in the Enterprise-to-Community Edition downgrade path that may allow an authorized caller to crash the Consul server. A caller with config-entry write permission can submit a service-router configuration entry that causes the agent to exit unexpectedly. This vulnerability, CVE-2026-19012, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.

Affected products

How to fix

Upgrade to a fixed version: HashiCorp Consul 2.0.3; HashiCorp Consul Enterprise 2.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-19012 or the next vulnerability affects your stack