What’s Vulnerable › Vulnerabilities
CVE-2026-19050: ProSolution WP Client < 2.0.9 - Subscriber+ SSRF via proSol_url_validate
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-12 · updated 2026-08-26
- Weakness: CWE-918
Description
The ProSolution WP Client WordPress plugin before 2.0.9 does not validate a user-supplied URL, and does not check the capability or nonce of the requester, before performing a server-side HTTP request with it, allowing any authenticated user, such as a subscriber, to make the site issue arbitrary requests to internal hosts and services, including requests with an attacker-chosen method, headers and body.
Affected products
- ProSolution WP Client: before 2.0.9 — fixed in 2.0.9
How to fix
Upgrade to a fixed version: ProSolution WP Client 2.0.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-19050 or the next vulnerability affects your stack