What’s Vulnerable › Vulnerabilities
CVE-2026-19055: ProSolution WP Client < 2.0.11 - Reflected XSS via Multiple Parameters
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-10-22
- Weakness: CWE-79
Description
The ProSolution WP Client WordPress plugin before 2.0.11 does not sanitise and escape several parameters before reflecting them into HTML attributes on its public pages, leading to reflected Cross-Site Scripting that can be triggered against any visitor, including a logged-in administrator.
Affected products
- ProSolution WP Client: before 2.0.11 — fixed in 2.0.11
How to fix
Upgrade to a fixed version: ProSolution WP Client 2.0.11. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-19055 or the next vulnerability affects your stack